Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
moebounejlbmehp08d3n
18.10.2021 13:29 •
Информатика
Задать массив m(12) случайными числами от 9 до 54. увеличить на 5 элементы массива, кратные 3. увеличить на 5 элементы массива, кратные 3, стоящие на четных местах.
Показать ответ
Ответ:
Løæålø
04.10.2020 09:06
Var
a:array[1..12] of integer;
i:integer;
begin
for i:=1 to 12 do
begin
a[i]:=random(45)+9;
write(a[i]," ");
end;
writeln();
for i:=1 to 12 do
begin
if ((a[i] mod 3)=0) and ((i mod 2)=0) then
a[i]:=a[i]+5;
if ((a[i] mod 3)=0) then
a[i]:=a[i]+5;
write(a[i]," ");
end;
end
0,0
(0 оценок)
Популярные вопросы: Информатика
karinayatskevioz1zkj
28.03.2022 16:04
Программа запрашивает число n. Далее, мы вводим n чисел и сохраняем все введенные числа в список. Далее, программа запрашивает пользователя число m. Если число m...
farid2008farid
23.03.2022 19:22
turbo pascal по номеру квартиры определить этаж и подъезд. Дом 3-х подъездные, 4-х этажный, 5 квартир на одном этаже. решать через...
ильзат12
09.07.2022 14:16
Чему равна сумма чисел 13^8 и 13^16?Результат запишите в двоичной системе счисления...
lessy2014owrwk6
09.06.2021 12:31
3. Чему равно значение вы • not (1 or 0 and 1) 1 аnd nоt O • 1 and 0 or 1...
Franikforever79
01.07.2022 03:47
Информатика , 8 класс....
imranesedov777
08.03.2022 19:07
решить, буду очень благодарна...
Ванесса07
08.06.2021 14:10
Очень надо... В мастерской над заказом трудятся 4 мастера и подмастерье. Первый мастер выполнил 1/5 заказа, второй мастер - 1/4 оставшегося заказа, третий - 1/3 нового...
ianna9227p00tfn
06.02.2023 21:54
3. Complete the second sentence so that it has similar meaning to the first se1 the word given but do not change it. ( use between 2-5 words) a) The teacher is looking...
полина2124
11.11.2022 12:57
1.Чем удивительна была находка Агея и его деда? Отметьте ДВА правильных ответа. А. Они нашли метеорит поразительных размеров. Б. Они нашли редкий камень больших размеров....
dmi3Mikh
27.07.2020 14:32
Кто такой Ермак в чем его заслуга перед государством ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a:array[1..12] of integer;
i:integer;
begin
for i:=1 to 12 do
begin
a[i]:=random(45)+9;
write(a[i]," ");
end;
writeln();
for i:=1 to 12 do
begin
if ((a[i] mod 3)=0) and ((i mod 2)=0) then
a[i]:=a[i]+5;
if ((a[i] mod 3)=0) then
a[i]:=a[i]+5;
write(a[i]," ");
end;
end