В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
masya05781
masya05781
30.10.2020 05:01 •  Информатика

Задать массив из n элементов. значения вести с клавиатуры. написать программу, уменьшающую все элементы массива на единицу. вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив. для перехода на новую строку добавить writeln. это все в pascal abc

Показать ответ
Ответ:
илюхаaaaa
илюхаaaaa
13.07.2020 10:19
Const n=10000;
var a:array [1..n] of integer;
b:array [1..n] of integer;
i, k:integer;
begin
Writeln ('Введите число элементов массива');
readln (k);
for i:=1 to k do begin
Writeln ('Введите ',i,' элемент массива'); readln (a[i]); end;
for i:=1 to k do begin b[i]:=a[i]-1; end; 
Writeln ('Первоначальный массив:'); 
for i:=1 to k do begin writeln (a[i]); end; 
Writeln ('Конечный массив:'); 
for i:=1 to k do begin writeln (b[i]); end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота