В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nataly163
nataly163
06.12.2020 22:54 •  Информатика

Заданы 5 чисел напишите программу которая выведет их в обратном порядке при этом переставив все цифры в каждом числе в обратном порядке

Показать ответ
Ответ:
ooz
ooz
09.10.2020 19:38

const N=5;

var a:array [1..N] of integer;

i:integer;

s:string;

BEGIN

for i:=1 to N do

read(a[i]);

s:='';

for i:=N downto 1 do begin

while a[i]>0 do begin

s:=s+a[i] mod 10;

a[i]:=a[i] div 10;

end;

write(s,' ');

s:='';

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота