Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
WhiteBurn
02.11.2022 20:14 •
Информатика
Задано трехзначное число, написать программу на языке паскаль, которая находит сумму его цифр и проверить четное оно или нет.
Показать ответ
Ответ:
nastgoliakova
01.10.2020 15:14
Program gt;
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lenamolchanova1
27.05.2022 00:45
Ввершинах графа записаны буквы. каждое реброребросо стрелкой означает: к букве добавляется одна чёрточка и получается новая буква....
mandarinochkin
14.12.2022 00:59
Всегда ли при решении вы получали новую информацию? примеры....
caramelka05
14.12.2022 00:59
Решить )) графическое изображение размером 100 на 150 пикселей из 256 цветной палитры преобразовали в 16 цветную. как изменился информационный объём изображения?...
опв4
30.07.2022 16:29
Ученик решил создать в игровой среде игру Сбор яблок на торелке определите необходимые спрайты...
Olenizbugushego
03.05.2023 11:54
Сор по информатике 6 класс 3 четверть. Скажите...
RK2890
06.09.2022 02:54
Составить программу в учебной среде программирования КУМИР (Линейныйалгоритм)1. Найти площадь прямоугольного треугольника по двум его сторонам....
РоманРазумный
16.01.2023 19:59
Составить программу в учебной среде программирования КУМИР (Конструкция«ветвление»):2. Дано целое число. Если оно является положительным, то прибавить к нему 1;...
doc9w
06.03.2022 00:13
Как удалить гиперссылку...
annatiko1984
11.11.2020 21:44
Для чего используется предворительный...
SaBzZiRo
25.02.2023 02:00
Как вставляется гиперссылка?Как вставить гиперссылку на иллюстрацию?Как удалить гиперссылку?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.