В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Soffa6110
Soffa6110
12.11.2022 23:28 •  Информатика

Задание. В двумерном массиве B, состоящем из N строк и M столбцов,
находятся размеры начисленной заработной платы N работников предприятия за
M месяцев, т. е. B[ I, K ] – это заработная плата работника предприятия с
номером I за месяц с номером K.
Составить программу, позволяющую выполнить:
ввести с клавиатуры количество работников и количество месяцев, а также
размеры заработной платы, для ввода исходных размеров заработной платы
использовать подпрограмму-процедуру;
определить наименьшую заработную плату за месяц с номером 1;
Исходные данные:
N – количество работников предприятия (целое число);
M – количество месяцев (целое число);
B[ I, K ] (I = 1, 2, 3,…, N; K = 1, 2, 3,…, M) – массив значений заработной
платы (значения вещественного типа);
Требуется определить:
MIN – наименьшую заработную плату за месяц с номером 1 (число с
дробной частью);
Формализация задачи
Значения заработной платы представляют собой конечный набор (N´M
значений) однотипных данных. Для их хранения можно использовать двумерный
массив В, состоящий из N строк и M столбцов ( B [ 1, 1 ] – заработная плата
работника номер 1 за первый месяц, B [ 1, 2 ] – заработная плата работника
номер 1 за второй месяц, B [ 2, 1 ] – заработная плата работника номер 2 за
первый месяц и т.д.
Абстрагируясь от физического смысла значений элементов массива,
сформулируем задачу обработки абстрактного двумерного массива B.

Показать ответ
Ответ:
WaySu
WaySu
14.04.2021 05:51

Никита,оставшись.один,пошёл в сарай и увидел там пустую бочку.Он думал,что в ней живёт маленький человечек с длиной бородой.Никита разговаривал с ним,по отдать ножницы,которые пропали у мамы.За деревней кто-то ухнул.Бочка отозвалась страшным голосом.Никита испугался и по защиты у солнца.

Солнце было доброе и ласковое.Никита подумал,что это дедушка теперь живёт на солнце.

За огородом находился старый колодец.Никита думал,что на дне живут маленькие водяные жители,толстые,безволосые и вредные.Потом ему представилось,что там ещё и великан.

У сарая он увидел две земляные норы.Он решил,что это змеиные норы.

Никита увидел на огороде старый пень и решил,что это голова человека.Лицо у пня было сердитое.

Он смотрел на старую баню и думал.что это бабушка превратилась в избушку.

Петух представлялся ему пастухом,а цветок-маленьким ребёнком.

0,0(0 оценок)
Ответ:
temaimcheg
temaimcheg
24.11.2021 01:35
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота