В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vishenka333
Vishenka333
12.06.2022 06:51 •  Информатика

Задание: Напишите программу, которая в последовательности чисел определяет максимальное число, оканчивающееся на 1. На вход программа получает числа: 3, 11, 21, 31. Количество чисел не превышает 1000. Величина чисел не превышает 30000.
Я пишу программу:
var n, a, i:integer;
begin
readln(n);
min(n) :=30001; (вот здесь он ругается "нельзя присвоить левой части")
for i:=1 to n do
begin
readln(a);
if (a mod 16 = 0) and (a then min:=a;
end;
writeln(min);
end.

Что не так??? Объясните И если есть еще ошибки, исправьте

Показать ответ
Ответ:
anna666666666666
anna666666666666
29.11.2022 17:37
Function IsPrime(n: Longint): Boolean;
var i, sqrtn, delta: Word;
begin
  if (n >= 5) and ((n - 1) mod 6 = 0) or ((n + 1) mod 6 = 0) then begin
    i := 5;
    delta := 2;
    sqrtn := Trunc(sqrt(n));
    IsPrime := False;
    while i <= sqrtn do begin
      if n mod i = 0 then Exit;
      Inc(i, delta);
      delta := delta xor 6; {смена шага, то 2, то 4}
    end;
    IsPrime := True;
  end else
    IsPrime := (n = 2) or (n = 3);
end;
Var A,B,i : Integer;
Begin
  Readln(A,B);
  For i:=A to B do If IsPrime(i) then Writeln(i);
end.
0,0(0 оценок)
Ответ:
alesa6002
alesa6002
09.08.2020 20:26

Відповідь:

Дивись код на фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота