В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyluk125
nastyluk125
23.04.2022 00:01 •  Информатика

Задание
Написать программу на языке питон
Случайно рядом.
Заполните массив случайными N - числами в интервале [0,5]. Определить, есть ли в нем элементы с одинаковыми значениями, стоящие рядом.
Формат входных данных
N. N – целое число, в диапазоне от 1 до 1 000 000.
Формат выходных данных
Вывести полученный массив, в первой строке, каждый элемент через пробел. Далее, если в массиве есть одинаковые элементы стоящие рядом, ты вывести «YES» и через пробел индексы таких элементов. В противном случае вывести NO.
Пример
Входные данные
Выходные данные
6
1 2 3 3 2 1
YES 2 3
6
NO
• В примере только формат вывода. Т.к. элементы случайны, даже при одинаковых входных данных, результат может быть разный.

Показать ответ
Ответ:
sofia121324oyztor
sofia121324oyztor
06.03.2021 18:17

#include <iostream>

#include <vector>

using namespace std;

void bubbleSort(vector<int> &a_){

   vector<int> t;

   int n = a_.size();

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a_[j] > a_[j + 1])

               swap(a_[j], a_[j + 1]);

   for(auto &i: a_) if(i & 1) t.push_back(i);

   a_ = t;

}

void solve(){

   vector<int> a = {2, 10, 5, 3, 11, 9, 12};

   bubbleSort(a);

   cout << "a = {";

   for(int i = 0; i < a.size() - 1; i++)

       cout << a[i] << ", ";

   cout << a.back() << "}";

}

int main(){

   solve();

}

0,0(0 оценок)
Ответ:
MrBOPOH
MrBOPOH
08.01.2021 16:36

Объяснение: Настольный теннис — олимпийский вид спорта, спортивная игра с мячом, в которой используют специальные ракетки и игровой стол, разграниченный сеткой пополам. Игра может проходить между двумя соперниками или двумя парами соперников. Задачей игроков является удерживать мяч в игре при ракеток — каждый игрок после одного отскока мяча на своей половине стола должен отправить мяч на половину стола соперника. Очко начисляется игроку или паре игроков, когда соперник не может вернуть мяч в соответствии с правилами. Каждая партия продолжается до 11 очков, матч состоит из нечётного количества партий, и играется на большинство побед в партиях.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота