В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
efimovvvilyha
efimovvvilyha
04.08.2021 19:11 •  Информатика

Задание для выполнения:
1. Составить программу вычисления значения выражения по формуле:
у = (2а+в+5с):(а*5в+с), если а, в – переменные действительного типа, а переменная с – целого типа.
3. Составить программу вычисления площади трапеции с основанием S по формуле S=EF*H, если EF= (BC+AD)/2; H =10
4. Составить программу вычисления общей поверхности и объема круглого конуса, имеющего радиус основания R=12,54 см и длину образующей L=24,83 см. При вычислениях использовать равенства:
S = πR2 + RL; V= 1/3 πR2H, где Н – высота конуса, определяемая по формуле H = √(L^2+R^2 )

Показать ответ
Ответ:
ivanovaa750
ivanovaa750
26.11.2020 10:54

В задании указано сделать дружественную функцию для того чтобы устанавливать новую цену на книгу, но не указано делать поле price, поэтому я его добавил (с типом double).

Мой вариант:

#include <iostream>

#include <string.h>

using namespace std;

class Book

{

   char *autor;

   char name[50];

   int year;

   double price;

public:

   Book()

   {

       autor = new char[50];

       strcpy(autor,"undefined");

       strcpy(name,"undefined");

       year=0;

       price=0;

   }

   Book(char *name, char *autor, int year, double price)

   {

       this->autor = new char[50];

       this->year=year;

       strcpy(this->name,name);

       strcpy(this->autor,autor);

       this->price=price;

   }

   ~Book()

   {

       delete[]autor;

   }

   char* getName() { return name; }

   char* getAutor() { return autor; }

   double getPrice() { return price; }

   int getYear() { return year; }

   friend  void setPrice(Book& obj, double price);

   friend  void setYear(Book& obj, int year);

};

void setPrice(Book& obj, double price)

{

   obj.price = price;

}

void setYear(Book& obj, int year)

{

   obj.year = year;

}

int main()

{

   Book b("Harry Potter","Joanne Rowling",1995,100);

   cout << "Book name - " << b.getName() << endl;

   cout << "Autor name - " << b.getAutor() << endl;

   cout << "Release year - " << b.getYear() << endl;

   cout << "Book price - " << b.getPrice() << endl;

   setPrice(b,150);

   setYear(b,1997);

   cout << "New book price - " << b.getPrice() << endl;

   cout << "New release year - " << b.getYear() << endl;

   cin.get();

   cin.get();

}

0,0(0 оценок)
Ответ:
даночкаа88
даночкаа88
22.08.2020 04:21

World Wide Web

Объяснение:

Всеми́рная паути́на (англ. World Wide Web) — распределённая система, предоставляющая доступ к связанным между собой документам, расположенным на различных компьютерах, подключённых к сети Интернет. Для обозначения Всемирной паутины также используют слово веб (англ. web «паутина») и аббревиатуру WWW.

Всемирную паутину образуют сотни миллионов веб-серверов. Большинство ресурсов Всемирной паутины основано на технологии гипертекста. Гипертекстовые документы, размещаемые во Всемирной паутине, называются веб-страницами. Несколько веб-страниц, объединённых общей темой или дизайном, а также связанных между собой ссылками и обычно находящихся на одном и том же веб-сервере, называются веб-сайтом. Для загрузки и веб-страниц используются специальные программы — браузеры (англ. browser).

Всемирная паутина вызвала настоящую революцию в информационных технологиях и дала мощный толчок развитию Интернета. В повседневной речи, говоря об Интернете, часто имеют в виду именно Всемирную паутину. Однако важно понимать, что это не одно и то же.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота