В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dasha148ttt
dasha148ttt
28.11.2021 18:15 •  Информатика

Задание 5. Составьте программу подсчета количества часов, минут и секунд в данном числе суток. Число суток введите с клавиатуры.​

Показать ответ
Ответ:
Rilon
Rilon
21.01.2021 20:30

Неправильно считает секунды, в чём ошибка?

var

s,m,h,days: integer;

begin

writeln('Введите кол-во дней');

read(days);

s:=86400;

m:=s div 60;

h:=m div 60;

for var i:=1 to days do

s:=s*days;

m:=m*days;

h:=h*days;

writeln(s,' — секунд в ',days,' днях');

writeln(m,' — минут в ',days,' днях');

writeln(h,' — часов в ',days,' днях');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота