В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Astronavtka
Astronavtka
28.06.2022 10:32 •  Информатика

Задание 3
Чему равно значение s после выполнения цикла
Program T3;
var s,k: integer;
begin
s := 2;
for k := 1 to 3 do
s := s * s;
writeln(s);
end.
Задание 4
Чему равно значение s после выполнения цикла
Program T4;
var s,n: integer;
begin
s := 0;
for n := 3 to 7 do
s := s + 2*n;
writeln(s);
end.
Задание 5
Чему равно значение s после выполнения цикла
Program T5;
var s,k: integer;
begin
s := 0;
for k := 6 to 12 do
s := s + 5;
writeln(s);
end.

Показать ответ
Ответ:
Liza6789456
Liza6789456
06.05.2020 19:04
Const n=10;
var 
  k,l,m,i,j: integer;
  var a: array[1..n] of integer;
begin
  k:=0; m:=0; j:=0; l:=0;
  for i:=1 to n do begin
    a[i]:=random(10);
    write (a[i]:3);
    if (i>1) and (a[i]>=a[i-1]) 
      then begin k:=k+1; j:=i; end
      else 
        if (k>0) and (k>l) 
          then begin l:=k; m:=j; k:=0 end
          else k:=0;
  end;
  if (k>0) and (k>l) 
    then begin l:=k; m:=n end; 
  writeln;
  writeln;
  for i:=m-l to m do 
    write (a[i]:3);
  l:=l+1;
  writeln;
  writeln ('Длина = ',l)
end.
результат:
  9  2  5  0  8  5  7  7  3  7

  5  7  7
Длина = 3

* рандомный ввод массива можно заменить обычным с клавиатуры
0,0(0 оценок)
Ответ:
arseniy2607
arseniy2607
31.03.2022 22:12
Проще всего для решения использовать круги Эйлера (см. фото)

Запрос А) (Париж & Москва) | Прага занимает сектора B,E,D,F,G
Запрос Б) Париж | Москва | Прага занимает все сектора A,B,C,D,E,F,G
Запрос В) (Париж | Москва) & Прага занимает сектора D,E,F
Запрос Г) Париж & Москва & Прага занимает только сектор E

Отсюда видно, что запрос Г) самый маленький. Его превосходит запрос В). Его в свою очередь превосходит запрос А). И самый большой - запрос Б)
Осталось расположить их в порядке убывания

ответ: Б А В Г
Втаблице запросы к поисковому серверу. для каждого запроса указан его код - соответствующая буква от
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота