В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
глеб380
глеб380
26.10.2022 15:59 •  Информатика

Задание 2. Николай решил написать программу для решения уравнения x-2b=a (a и b задаются с клавиатуры)

A. Составьте алгоритм решения данного уравнения

B. Составьте блок схему для решения уравнения x-2b=a

[2]

Задание 3. Азату дали задание написать программу нахождения квадратов чисел в диапазоне от a до b (a и b задаются с клавиатуры). Укажите, какую алгоритмическую конструкцию необходимо использовать для решения этой задачи?

[1]

Задание 4. По данной блок –схеме дополните псевдокод недостающими командами в теле цикла.

алг сумма

вещ a,s

нач

S:=0;

A:=1;

нц

1.

2.

3.

кц

вывод S

кон заранее ОГРОМНОЕ

Показать ответ
Ответ:
Fantom511
Fantom511
02.07.2020 22:17

Для  данной сортировки используем алгоритм сортировки слиянием

В начале разбиваем арбузы на 2 группы по 2Каждую группу взвешиваем и сортируем (т.е. всего 2 взвешивания)Теперь собираем вместе, сравниваем сначала более легкие арбузы и находим самый легкий (всего 3 взвешивания)Теперь сравниваем тяжелый арбуз, что в группе с самым легким и более легкий из другой группы, и определяем второй по легкости (всего 4 взвешивания)Потом взвешиваем оставшиеся арбузы и докладываем их  по порядку (всего 5 взвешивания)
0,0(0 оценок)
Ответ:
123HelpMe123
123HelpMe123
09.09.2021 13:10
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота