Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
SmartFox1
04.06.2021 08:12 •
Информатика
Задан массив из 10 целых чисел.обменять значениями третий и предпоследний элемент массива.
Показать ответ
Ответ:
Пупырка20001
24.06.2020 20:25
Mas- имя массива
Mas[3]:= mas[3] +mas[10];
Mas[10]:=mas[3]-mas[10];
Mas[3]:=mas[3]-mas[10];
Всё, это поменяет местами значения
0,0
(0 оценок)
Ответ:
dashalev2510
24.06.2020 20:25
var
a: array [1..10] of integer;
x,i: integer;
begin
writeln('Заполните массив: ');
for i:=1 to 10 do read(a[i]);
x:=a[3];
a[3]:=a[9];
a[9]:=x;
for i:=1 to 10 do write(a[i]:4);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Ris1234
24.01.2020 05:33
Верно ли утверждение, что языки программирования высокого уровня ближе к человеческому пониманию и записывается в текстовом режиме? •верно•неверно 2. Определите тип данных переменнойа=31.5*•int...
yakormnevzad
20.06.2020 22:02
Текстовый файл 24.txt содержит последовательность из строчных и заглавных букв английского алфавита и цифр, всего не более 106 символов. Определите длину наибольшей возрастающей...
vladrifeyt1
15.02.2020 22:12
У славнозвісного Козака Вуса є менш відомий друг Возак Кус. Він обожнює додавати числа в стовпчик, але, на превеликий жаль усієї його родини, робить це неправильно. Возак Кус додає...
dikozzz
07.08.2020 02:41
Сжатие флагов . Битовый графический формат GIW использует следующий алгоритм сжатия данных. Каждая строка сжимается отдельно. Каждый цвет задаётся трёхбуквенным кодом. Последовательность...
funtya77
07.03.2021 02:24
с этим Мне компьютер говорит что с эта формула неправильна но почему и как её исправить?Формула:=IF(B2 (MAX(B$2:B$10)-MIN(B$2:B$10))*90%*; ;=IF(B2 MIN(B2:B10)+20%*(MAX(B$2:B$10)-MIN(B$2:B$10))*70%;...
ogorodnikovkir
27.07.2020 14:35
Паскаль На вход программе даётся n чисел,программа выдаёт среднее арифметическое чисел,которые делятся на 3 без остатка и заканчиваются на 8...
сова154
06.04.2022 23:03
Теория игр. ЕГЭ Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может...
manukansona
09.04.2020 17:29
Функция кнопки: А) регистрация файлаБ) открыть доступС) просмотр недавних действийВ) предварительный просмотрЕ) удалить документблагодарю заранее ❤️...
Аngel11
12.01.2023 03:40
Кундылык, аныктылык, озектилик аудару орысша агылшынша...
АняЕнот
19.01.2023 17:37
1710,1726 жылдардағы ұйымдастырылған құрылтайларға салыстырмалы талдау жаса...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Mas[3]:= mas[3] +mas[10];
Mas[10]:=mas[3]-mas[10];
Mas[3]:=mas[3]-mas[10];
Всё, это поменяет местами значения
a: array [1..10] of integer;
x,i: integer;
begin
writeln('Заполните массив: ');
for i:=1 to 10 do read(a[i]);
x:=a[3];
a[3]:=a[9];
a[9]:=x;
for i:=1 to 10 do write(a[i]:4);
end.