В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
plz11POMOGITE11plz
plz11POMOGITE11plz
05.08.2020 07:12 •  Информатика

Задан числовой массив, состоящий из 9 элементов. найти и вывести на экран произведение всех элементов, меньших максимального.надо составить программу.,

Показать ответ
Ответ:
Katesinful
Katesinful
21.07.2020 11:54
Program programma;
uses crt;
var
a:array[1..100]of integer;
i,max,p:integer;
begin
clrscr;

p:=1;
for i:=1 to 9 do
begin
write('a[',i,'] = ');
readln(a[i]);
end;

for i:=1 to 9 do
begin
if a[i]> max then max:=a[i];
end;

for i:=1 to 9 do
begin
if a[i]<> max then
p:=p* a[i]
end;
writeln;
writeln('max = ', max);
write('P = ',p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота