В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
лёхыч3
лёхыч3
27.08.2022 21:04 •  Информатика

Задали по информатике, . составьте программу, которая запрашивает значения элементов одновременного числового массива a, состоящего из 10 элементов, формирует и выводит на экран в строку данный массив. найти сумму элементов массива, не равных нулю.

Показать ответ
Ответ:
studentASH
studentASH
07.11.2022 11:13

Здравствуйте!

Зовут меня Алексеева Ольга Вячеславовна, но друзья обычно называют меня Оленькой. У меня много хобби  и пристрастий: я люблю заниматься вышивкой гладью и вязанием на спицах, люблю читать, преимущественно детективы. Моя любимая книга детективного жанра - "Приключения Шерлока Холмса" Сэра Артура Конан Дойля. Еще я получаю огромное удовольствие от просмотра документальных фильмов. Больше всего мне нравится исторический сериал "Великая". Помимо этого я питаю слабость к классической музыке. Я восхищаюсь и с наслаждением слушаю Шопена и симфонии Моцарта. А что касается стиля в одежде - то здесь я предпочитаю удобный стиль "Кэжуал".

за внимание!

0,0(0 оценок)
Ответ:
Djanik228
Djanik228
28.09.2021 13:16

#include <iostream>

#include <time.h>

#include <cstdlib>

using namespace std;

int main() {

int n, s = 0, max = 0, min = 9;

srand(time(NULL));

 

do {

 cout << "Input size of matrix: n = ";

 cin >> n;

 if (n < 0)  

 {

  cout << "Input error! n < 0. Please try again" << endl;

  continue;

 }

 else break;

} while (true);

 

int **matr = new int* [n];

for(int i = 0; i < n; i++)

 matr[i] = new int [n];

 

for (int i = 0; i < n; i++)  

{

 for (int j = 0; j < n;j++)  

 {

  matr[i][j] = rand() % 10;

  cout << matr[i][j] << " ";

 }

 cout << endl;

}

 

for (int i = 0; i < n; i++)  

{

 if (max < matr[i][i])

  max = matr[i][i];

 if (min > matr[i][n-i-1])

  min = matr[i][n-i-1];

 s += matr[i][i] + matr[i][n - i - 1];

}

if (n % 2 != 0)

 s -= matr[n / 2][n / 2];

cout <<"Maximum number on the main diagonal: " << max << endl << "Minimum number on the secondary diagonal: " << min << endl << "Sum of numbers on the diagonals: " << s;

 

return 0;

}

/* Редактор не сохраняет отступы зачастую, поэтому прикрепил .cpp файл с кодом */

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота