В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
farangizuk
farangizuk
20.08.2022 11:26 •  Информатика

задачу по инфе на языке PYTHON! import random
x = random.randint(1, 10)
Преподаватель опрашивает учеников по списку класса в электронном журнале. Однако не все ребята успевают готовиться и вообще это не очень честно всегда спрашивать тех, кто на букву "А":)
Напишите программу, которая будет случайным образом выводить список учеников либо в алфавитном порядке, либо в обратном.

Пример списка:
spisok = ["Саша", "Артем", "Влад", "Макс", "Женя"]

Показать ответ
Ответ:
Ziko88881
Ziko88881
13.06.2021 19:02

import random

# Определяем список учеников

student_list = ["Александр", "София", "Мария", "Максим", "Михаил", "Артём", "Анна", "Даниил", "Иван", "Виктория",

               "Алиса", "Анастасия", "Дмитрий", "Полина", "Елизавета", "Александра", "Дарья", "Екатерина", "Кирилл"]

# Создаем цикл while

while True:

   # Создаем пользовательский ввод

   sort_type = input("Выберите метод сортировки учеников (r - случайно, a - в алфавитном порядке, ar - в алфавитном "

                     "порядке обратно): ")

   # Если выбран метод сортировки "r", сортируем список случайно и прерываем выполнение текущего цикла

   if sort_type == "r":

       random.shuffle(student_list)

       print(student_list)

       break

   # Если выбран метод сортировки "a", сортируем список в алфавитном порядке и прерываем выполнение текущего цикла

   elif sort_type == "a":

       student_list.sort()

       print(student_list)

       break

   # Если выбран метод сортировки "ar", сортируем список в алфавитном порядке обратно и прерываем выполнение

   # текущего цикла

   elif sort_type == "ar":

       student_list.sort(reverse=True)

       print(student_list)

       break

   # Если выбран неопределенный сортировки, выводим ошибку и возвращаемся к пользовательскому вводу

   else:

       print("Неизвестный метод сортировки.")


задачу по инфе на языке PYTHON! import random x = random.randint(1, 10) Преподаватель опрашивает уче
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота