Задачу нужно решить на питоне. Продукты и пакет Вася пришел в магазин с очень слабым пакетом, поэтому ему нужно посчитать, сколько всего весят продукты, которые он хочет купить. Зная общую массу продуктов, Вася определит, сможет ли он донести эти продукты.
Мы знаем, что вася хочет купить n продуктов. Вес каждого из продуктов ωi вася будет спрашивать у продавца и вводить в программу. Нам нужно посчитать сумму Σⁿi=1 ωi Входные данные В первой строке вводится натуральное число n - количество продуктов, которые хочет купить Вася. В последующих n строках вводится натуральное число ωi - масса одного из продуктов
Пользовательский интерфейс - это совокупность средств и правил взаимодействия человека и компьютера. взаимодействие человека и компьютера в наши дни строится на основе объектно-ориентированного графического интерфейса, в котором: все объекты представляются в виде значков; оперирование объектами осуществляется в окнах; основным элементом программного является меню; основным элементом аппаратного являются различные манипуляторы. информационное пространство пользователя - это информационные ресурсы (файлы с программами, документы, web-сайты, фотографии, видеофрагменты и доступные пользователю при работе на компьютере.
{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}
{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}
//pascal abc.net v3.0 сборка 1111
var
a,i,b,r,n,j,bug: integer;
s,se,slo,slof: string;
procedure preob(var a,b,n: integer; var se: string);
begin
repeat
b: =a mod n;
a: =a div n;
str(b,se);
s+=se;
until (a< =n-1);
end;
beginreadln(slo);
readln(n);
for j: =1 to length(slo) do
begin;
a: =ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i: =1 to length(s) div 2 do
begin;
se: =s[i];
s[i]: =s[length(s)-i+1];
s[length(s)-i+1]: =se[1];
end;
write(s,'-');
slof: =slof+s;
delete(s,1,length(s));
end;
end.
пример ввода:
работа на завтра.
2
пример вывода:
11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-
{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}