В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
victorov113
victorov113
07.04.2020 07:04 •  Информатика

Задачи для самостоятельного решения: 1. Составьте программу, которая выводит на экран следующие ряды чисел: 0, 5, 10, 15, 20, 25, 30 и 25, 20, 15, 10, 5, 0, -5.​

Показать ответ
Ответ:
123maladauskas
123maladauskas
08.06.2021 09:21
Высказывании (Y+1 > X) ∧ (Y+X <0) ∧ (X>1) истинно, если истинен каждый из трех предикатов.
1) X = 0,5; Y = -1,1
Y+1 > X; -1.1+1 > 0.5; -0.1 > 0.5 ложно и данный набор значений не подходит.
2) X = 1,1; Y = -4
Y+1 > X; -4+1 > 1.1; -3 > 1 ложно и данный набор значений не подходит.
3) X = -1; Y = -4
Y+1 > X; -4+1 > -1; -3 > -1 ложно и данный набор значений не подходит.
4) X = -0,1; Y = -1,1
Y+1 > X; -1.1+1 > -0.1; 0-.1 > -0.1 ложно и данный набор значений не подходит.
ответ: все четыре варианта не подходят.
0,0(0 оценок)
Ответ:
Enotlk1337
Enotlk1337
17.01.2020 14:51
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=3;
 const int m=3;
 int ma[n][m];
 int c;
 cout<<"First matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   {ma[i][j]=i+j;
   cout<<ma[i][j]<<" ";}
  cout<<endl;}
 for(int i=0;i<n/2;i++){
  for(int j=0;j<m;j++)
   {c=ma[i][j];
   ma[i][j]=ma[n-i-1][j];
   ma[n-1-i][j]=c;}}
 cout<<"Final matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   cout<<ma[i][j]<<" ";
  cout<<endl;}
 return 0;
}

Пример работы программы(n=3,m=3):
First matrix:
0 1 2
1 2 3
2 3 4
Final matrix:
2 3 4
1 2 3
0 1 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота