В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ivanprofi22
Ivanprofi22
04.05.2022 22:27 •  Информатика

Задача: Опишите:

тип массив TStroka как массив целых чисел из MAX_NUM элементов (задано константой,описывать не надо) элементов с индексами от 1 до MAX_NUM;
тип массив TTablica как массив из строк целых чисел (TStroka) из MAX_NUM элементов (задано константой,описывать не надо) элементов с индексами от 1 до MAX_NUM;
процедуру procedure Zap(var m: TTablica), которая заполняет массив, заданным образом;
процедуру procedure Vivod(m: TTablica), которая выведет элементы массива в виде таблицы через один пробел.
Формат ввода:

Описан в задаче.

Формат вывода:

Описан в задаче.

Пример входных данных

Описан в задаче.
Пример выходных данных

0 0 0 1
0 0 1 1
0 1 1 1
1 1 1 1
Пояснение:

Отсутствует.

Показать ответ
Ответ:
RaminaMirzaeva
RaminaMirzaeva
15.07.2022 06:00
Компьютер быстро вошел в нашу жизнь. Еще несколько лет назад было редкостью увидеть какой-нибудь персональный компьютер – они были, но были очень дорогие, и даже не каждая фирма могла иметь у себя в офисе компьютер. А теперь? Теперь в каждом третьем доме есть компьютер, который уже глубоко вошел в жизнь человека. Современные вычислительные машины представляют одно из самых значительных достижений человеческой мысли, влияние которого на развитие научно-технического прогресса трудно переоценить. Для многих людей сейчас компьютер уже не роскошь, а необходимый предмет домашней или рабочей обстановки.
0,0(0 оценок)
Ответ:
Fela06
Fela06
11.03.2021 15:27
1. Короткое решение для числа произвольной длины (на символьной строке)

var
  s:string;
  c:char;
begin
  Write('Введите натуральное число: ');
  Readln(s);
  Write('введите искомую цифру: ');
  Readln(c);
  if Pos(c,s)>0 then
    Writeln('Такая цифра в числе есть')
  else
    Writeln('Такой цифры в числе нет')
end.

Тестовое решение
Введите натуральное число: 43543232
введите искомую цифру: 4
Такая цифра в числе есть

2. Более традиционное решение с целочисленными переменными

var
  s,c:integer;
  brk:boolean;
begin
  Write('Введите натуральное число: ');
  Read(s);
  Write('введите искомую цифру: ');
  Read(c);
  brk:=false;
  repeat
    if s mod 10=c then brk:=True;
    s:=s div 10
  until brk or (s=0);
  if brk then
    Writeln('Такая цифра в числе есть')
  else
    Writeln('Такой цифры в числе нет')
end.

Тестовое решение
Введите натуральное число: 43543232
введите искомую цифру: 6
Такой цифры в числе нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота