В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
maximiva7273737
maximiva7273737
20.03.2021 14:45 •  Информатика

Задача No3
Составить программу разложения натурального числа n на множители.
пример: 360 = 2 2 2 3 3 5. Посчитать количество разных множителей.
our
python цикл while​

Показать ответ
Ответ:
опчарготь
опчарготь
11.10.2020 21:48

n = int(input())

divisor = 2

unique = set()

while n > 1:

   if n % divisor == 0:

       print(divisor, end=' ')

       unique.add(divisor)

       n //= divisor

   else:

       divisor += 1

print('\nКоличество уникальных делителей: {0}'.format(len(unique)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота