В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gazizkadyrzhan
gazizkadyrzhan
29.09.2020 02:28 •  Информатика

ЗАДАЧА НА ПИТОНЕ Рабочие поднимают на грузовом лифте ящики. Если ящик весит больше 180 кг, то лифт отказывается его поднимать. Напишите программу, которая будет подсчитывать, сколько ящиков было поднято на грузовом лифте и общую массу ящиков, которые лифт поднять не смог.

С клавиатуры вводятся массы всех ящиков (в кг), символ окончания ввода - это ноль.

Формат входных данных
Последовательность целых положительных чисел, на конце ноль.

Формат выходных данных
ответ в формате:

Было поднято N ящиков, но еще K кг груза ожидают внизу.

Показать ответ
Ответ:
Nasya156
Nasya156
29.11.2021 20:30

boxes = []

count = 0

waiting = 0

for i in range(10):

  new_box = (int(input(f"Введите массу {i} ящика")))

  if new_box > 180:

     waiting = waiting + new_box

  else:

     count = count + 1

     boxes.append(new_box)

print(f"Было поднято {count} ящиков, но ещё {waiting} кг груза ожидают внизу.")


ЗАДАЧА НА ПИТОНЕ Рабочие поднимают на грузовом лифте ящики. Если ящик весит больше 180 кг, то лифт о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота