В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vasilisa00700
Vasilisa00700
03.07.2020 06:22 •  Информатика

Задача 3 Напишите программу, которая вычисляет значение выражения по известной
формуле
x+yx+1-x×y-1234+xx+yx+1-x×y-1234+x переменные целого типа, вводятся с клавиатуры (в одной строке два
числа).
Программа должна вывести одно число - результат вычисления выражения.​
.

Показать ответ
Ответ:
аня2942
аня2942
04.09.2022 16:23

Пример работы на рисунке 1.

Код:

#include <iostream>

#include <clocale>

#include <string>

using namespace std;


int main() {

setlocale(LC_ALL, "Russian");


//Входные данные

int K = 43;


if(K < 1 || K > 365) {

 cout << "Неверные входные данные";

 return 1;

}

// Дни

string Days[] = { "Понедельник", "Вторник", "Среда", "Четверг", "Пятница", "Суббота", "Воскресение" };

int N = K % 7;

cout << "День года №" << K << " называется " << Days[N] << endl;

system("pause");

return 0;

}


Вс++ дни недели пронумерованы следующим образом: 1- понедельник, 2 -вторник, ..6-суббота, 7 - воскре
0,0(0 оценок)
Ответ:
Alllexxxsss
Alllexxxsss
13.12.2022 06:00

Программа представленна ниже. Скриншот с результатами исполнения в приложениях.


#include <iostream>//cin

#include <cstdlib> //rand()

#include <algorithm>//sort()

#include <ctime>//time()

using namespace std;


#define N 5 // Количество элементов в массиве


bool moreThen(int a, int b) {

return ( a > b );

}


int main() {

int Arr[N];

srand(static_cast<unsigned int>(time(0))); //Инициализация генератора случайных чисел

cout << "Исходный массив: ";

for(int i = 0; i < N; ++i){

 Arr[i] = -rand(); //Заполнение случайными числами

 cout << Arr[i] << " ";

}

cout << endl;

cout << "Отсортированный массив: ";

sort(Arr, Arr+N, moreThen); //Сортировка с использованием stl

for(int i = 0; i < N; ++i){

 cout << Arr[i] << " ";

}

cout << endl;

return 0;

}


Отсортировать массив, состоящий из отрицательных чисел. (выберу лучший ответ, +60 ) на c++. 7 поясне
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота