В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vika78678
vika78678
30.03.2023 19:33 •  Информатика

ЯЗЫКИ ПИТОН И С++ Обратное число
В этой задаче нужно ответить на 1≤t≤105 за Каждый за состоит из двух целых чисел 2≤p≤109 и 0
Входные данные
В первой строке дано целое число t — количество за
В следующих t строках даны по два числа pi и ai, i=1,…,t.

Выходные данные
Выведите t целых чисел (каждое число в отдельной строке) — ответы на за

Примеры
Ввод
4
5 1
5 2
5 3
5 4
Вывод
1
3
2
4

Показать ответ
Ответ:
АртёмПлотников
АртёмПлотников
21.10.2021 01:31
Осенью я  ехала на дачу с семьёй отдыхать.  И тут вижу  кто-то рвёт все листья  из  деревьев , этот человек был в чёрном плаще и  в остроконечной  шляпе. Я  сказала  папе давай остановимся  тут, не  будем ехать на  дачу . И  папа ответил хорошо, давайте  остановимся  тут. Мы  остановились  не  далеко от  того места где  я видела этого человека . И я  сказала маме что хочу не много прогуляться и  мама сказала иди только  не далеко и я пошла в то место где  я видела этого человека ,  не  сказав  об  этом ни кому . Я  пошла  туда и увидела этого человека. Он куда то шёл и  я пошла  за  ним .   Вдруг вижу что этот человек хочет зайти в замок который шёл. Я была очень удивлена  этим замком и чуть не  ахнула от  страха  он  был весь чёрный и высокий, наверное этажей сто. И на  нём  везде были нарисованы  черепа .   Этот человек зашёл в  замок и я за  ним. Изнутри   замок   был  ещё хуже и страшнее чем снаружи . Там было полно летучих мышей и  ходящих скелетов . Хорошо  что я успела спрятаться   за  статуями иначе все.  Статуи тоже  двигались и  шатались . Одно статуе зарычало  на  меня и я убежала дальше.  Вхожу и вижу лабораторию   ведьмы. Оказывается  что  это не человек а ведьма. Я зашла туда и спряталась за  шкафом .   И вижу  тут ведьма кладёт в какой то  котел  листья  которые она рвала. . Она  сказала круцыо и вышла . Я  подошла   увидела  книгу заклинаний. Вдруг  пришла   ведьма и сказала на  меня заклинание бомба  макси я  успела  убежать .  Я  успела прочитать  заклинании из книги . Я притворилась  перед  ведьмой как будто я  тоже  злая .  И  она  поверила  мне .  В  руках  у неё  была  волшебная палочка . Она положила в  сторонку палочку . Потом  она  открыла шкаф . Там  были коробки волшебных  палочек . Она  попросила меня взять палочку и я взяла одну  палочку. Она  не  выбрала меня, я  взяла вторую тоже нет , я взяла  третью она  выбрала меня . Потом я  произнесла  заклинание редукто она убежала . Потом она сказала заклинание круцыо и я у бежала .  Потом  я произнесла заклинание Авадакидавра и  ведьма умерла. Вижу замок  начал падать и я убежала из замка. Снаружи осень уже стала ещё  красивее и лучше чем раньше. Я  вернулась к семье и они на меня толпой: где я была?   И тогда я  сказала сесть им на скамейку и я  начала рассказывать им  подробно о  своих приключениях. 
0,0(0 оценок)
Ответ:
Varbax896
Varbax896
02.04.2020 21:29
Var
a,b,c: integer;
begin
write('введите первую сторону треугольника ');
readln(a);
write('введите вторую сторону треугольника ');
readln(b);
write('введите третью сторону треугольника ');
readln(c);
if (a<0) or (a<0) or (b<0) then write('такого треугольника не существует ') else
if (a<>b) and (b<>c) then write('треугольник разносторонний') else
if (a=b) and (b=c) then write('треугольник равносторонний') else
if (a=b) or (a=c) or (b=c) then write('треугольник равнобедренный');
writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота