В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fgdfc1
fgdfc1
02.12.2022 14:35 •  Информатика

Язык с программированием. Заранее Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt

Сколько сантиметров в сантикилометре?
Это не совсем абракадабра, можно посчитать.

Приставка санти- означает деление на 100, приставка кило- – умножение на 1000. Значит, в сантикилометре 10 метров. А в метре – 100 сантиметров. Получаем ответ: в одном сантикилометре 1000 сантиметров.

Напишите программу, которая будет переводить такие странные единицы измерения – может быть много приставок санти- и много кило- – в сантиметры.

Формат ввода
Вводится слово, состоящее из произвольного количества приставок санти- и кило-, последним идет слово метр.

Формат вывода
Если получается целое число, то его и нужно выводить. Если получается дробь, то ее нужно выводить в виде:
1/<единица и необходимое количество нулей>.

Пример 1
Ввод сантикилометр
Вывод 1000

Пример 2
Ввод сантисантикилокилометр
Вывод 10000

Пример 3
Ввод
Вывод 1/1000

Примечания
В задаче нельзя использовать индексацию, срезы и методы строк.​

Показать ответ
Ответ:
AidarSharafutdinov
AidarSharafutdinov
07.01.2021 23:43
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Ответ:
siraevadiana
siraevadiana
16.04.2023 22:05
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота