В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lev93
lev93
26.12.2022 06:57 •  Информатика

Язык Python3 Простое число
По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число.

Входные данные

Во входном файле находится одно натуральное число K.

Выходные данные

В выходной файл выведите K-е простое число.

Примеры

Ввод:
3
Вывод:
5
Ввод:
1
Вывод:
2

Показать ответ
Ответ:
anastasiyaroma11
anastasiyaroma11
15.10.2020 14:00

Ну, можно так:

Объяснение:

def prostoe(chislo):

   a = True

   for i in range(2, chislo//2 + 1):

       if chislo % i == 0:

           a = False

           break

   return a

k = int(input("Введите число, не превосходящие 100000: "))

schetchic = 1

a = 2

while k >= schetchic:

   if prostoe(a):

       prostoi = a

       schetchic += 1

   a += 1

print(prostoi)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота