Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
anton4rf4
18.01.2021 20:53 •
Информатика
Язык программирования си 1.подсчитать общее число делителей натурального числа 2. с клавиатуры 2 прямые. определить их параллельность
Показать ответ
Ответ:
Александра894312
05.10.2020 17:33
Первое задание ->
#include <stdio.h>
int main(){
int N,O,K; // N - delimoe (vvodim s klaviaturq), O - ostatok ot delenija, K - chastnoe ot delenija
int i=1; //delitelj
int j=0; //kolichestvo delitelej
printf("Vvedite naturaljnoe chislo - ");
scanf("%d", &N);
do{
K=N/i;
O=N%i;
i++;
if(O==0){
//printf("\n%d", K); //vqvodim chisla
j++;
}
}while(K!=0);
printf("\n\nKolichestvo delitelej: %d\n", j);
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
demidboevoff
10.08.2022 01:28
1) в чем заключается магистрально модульный принцип настроения компьютера? 2) в чем состоит принцип программного ? 3) какие устройства называют мультимедийными и почему?...
lenalorax9093
12.09.2022 08:03
1. вещество, әнергия и информапия весьма схожи своими свой- ствами, проявляющимися в тех или иных процөссах. их можно по- лучать, передаватъ, хранить, обрабатывать....
foxi22
04.04.2021 23:46
Написать программу по блок схеме заранее )...
aidarbI4123
31.01.2022 12:46
Указать сумму покупки, количество монет в 10, в 5, в 2 и в 1 рублей, можно выдать сдачу. сделать в gdb online...
пистолетМакарова
16.11.2022 22:51
35 предсталение чисел в памяти пк: а)целые и вещественныеб)со знаком и без знакав)прямой, обратный дополнительный код....
AllaStepanova85
25.01.2020 02:33
Вgdb online- программирование! найти среднее арифметическое и среднее чисел введённых с клавиатуры!...
ITyanI
30.05.2023 08:12
Python дано 3 действительных числа а , б и с. если а больше б и б больше с каждое число увеличивается вдвое, по другому каждое число уменьшается на единицу. разобрать...
annswi
09.06.2022 10:11
Автомобиль, движущийся со скоростью 80 км/ч, обогнал велосипед, едущий в этом же направлении, и встретил мотоцикл, следующий ему навстречу. Скорость велосипеда относительно...
вира7
05.02.2023 08:18
В треугольнике abc bc=6 a=30°. Используя формулу а/sin a =2R...
kari2018
29.10.2020 06:45
Мне нужно сочинение на тему Важность математики кто сможет...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <stdio.h>
int main(){
int N,O,K; // N - delimoe (vvodim s klaviaturq), O - ostatok ot delenija, K - chastnoe ot delenija
int i=1; //delitelj
int j=0; //kolichestvo delitelej
printf("Vvedite naturaljnoe chislo - ");
scanf("%d", &N);
do{
K=N/i;
O=N%i;
i++;
if(O==0){
//printf("\n%d", K); //vqvodim chisla
j++;
}
}while(K!=0);
printf("\n\nKolichestvo delitelej: %d\n", j);
return 0;
}