Язык Питон и С++
Обратное число
В этой задаче нужно ответить на 1≤t≤105 за Каждый за состоит из двух целых чисел 2≤p≤109 и 0
Входные данные
В первой строке дано целое число t — количество за В следующих t строках даны по два числа pi и ai, i=1,…,t.
Выходные данные
Выведите t целых чисел (каждое число в отдельной строке) — ответы на за Примеры
Ввод
4
5 1
5 2
5 3
5 4
Вывод
1
3
2
4
Если будет две рабочих программы, добавлю балов(до 50)
program z1;
var
q, w, e, r, t, y, u, i, o, p, a, s, d, f, g, h, j, k, l, z: integer;
begin
writeln('Введите рост 1 учащегося');
readln(q);
writeln('Введите рост 2 учащегося');
readln(w);
writeln('Введите рост 3 учащегося');
readln(e);
writeln('Введите рост 4 учащегося');
readln(r);
writeln('Введите рост 5 учащегося');
readln(t);
writeln('Введите рост 6 учащегося');
readln(y);
writeln('Введите рост 7 учащегося');
readln(u);
writeln('Введите рост 8 учащегося');
readln(i);
writeln('Введите рост 9 учащегося');
readln(o);
writeln('Введите рост 10 учащегося');
readln(p);
writeln('Введите рост 11 учащегося');
readln(a);
writeln('Введите рост 12 учащегося');
readln(s);
writeln('Введите рост 13 учащегося');
readln(d);
writeln('Введите рост 14 учащегося');
readln(f);
writeln('Введите рост 15 учащегося');
readln(g);
writeln('Введите рост 16 учащегося');
readln(h);
writeln('Введите рост 17 учащегося');
readln(j);
writeln('Введите рост 18 учащегося');
readln(k);
writeln('Введите рост 19 учащегося');
readln(l);
writeln('Введите рост 20 учащегося');
readln(z);
writeln('Средний рост учащихся ', (q + w + e + r + t + y + u + i + o + p + a + s + d + f + g + h + j + k + l + z) / 20, ';');
end.
program Project1;
const
maxelem = 100;
var
a: array [1..maxelem] of integer; { Переменная для хранения массива.}
n: integer; { Переменная для хранения значения количества элементов в массиве.}
i,k: integer; { Вс переменные для организации циклов.}
sum: integer; { Переменная для хранения значения суммы выбранных величин роста}
begin
n:= 15;
for i:= 1 to n do
repeat
write('Введите значение ',i,' элемента: ');
Readln(a[i]);
if (a[i] < 150) or (a[i] > 200) then
writeln('Введенное число не входит в заданный диапазон.');
until (a[i] >= 150) and (a[i] <= 200);
writeln('Исходный массив: ');
for i:= 1 to n do
begin
write(a[i]:5);
if i mod 10 = 0 then
writeln;
end;
sum:= 0;
k:= 0;
for i:= 1 to n do
if a[i] > 180 then
begin
sum:= sum + a[i];
inc(k);
end;
writeln;
if k = 0 then
writeln('В классе нет учеников с ростом выше 180 см.')
else
writeln('Средний рост игроков баскетбольной команды: ',(sum/k):0:2);
Readln;
end.