ЯЗЫК ПАСКАЛЬ
ПАША И КУБИКИ
У маленького Паши было 5 кубиков с цифрами от 1 до 5 на каждом кубике. В не самый прекрасный день Паша обнаружил, что один из кубиков потерялся.
Паше понять, кубик с какой цифрой потерян, зная цифры на оставшихся кубиках. Формат входных данных: Программе на вход подаются 4 числа-цифры на оставшихся кубиках.
Формат выходных данных: Программа должна вывести одно число -цифру на кубике, который потерялся.
program Chernovik;
var a,b,c,d,i: integer;
begin
read(a,b,c,d);
for i:=1 to 5 do
if (i<>a) and (i<>b) and (i<>c) and (i<>d) then write(i)
end.
Объяснение:
Вводим числа
В цикле проверяем условие, если переменная цикла не равна ни одному из введенных чисел, то выводим её на экран