В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
romatopovsky
romatopovsky
14.09.2021 12:40 •  Информатика

ЯЗЫК ПАСКАЛЬ

Делёж яблок
N школьниксив делят К яблок поровну, неделяющийся остаток остается в корзинке. Напишите программу, которая определяет, сколько яблок достанеться каждому школьнику?
Формат входных данных: Программа считывает со стандартноно потока ввода (stdin) или из файла inрut.trt два натуральных числа К и N.
Оба числа не превосходят 10 000.
Формат выходных данных: Программа должна вывести на стандартный поток вывода (stdоut) или в файл оutрut.txt одно число-ответ на вопрос в условии задачи.​

Показать ответ
Ответ:
blin42p00v7h
blin42p00v7h
14.07.2022 03:43

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;


namespace avg_sort

{

   class Program

   {

       static void Main(string[] args)

       {

           const int N = 10;

           int[] Arr = new int[N];


           Random rand = new Random();

           Console.Write("Исходный массив: ");

           for (int k = 0; k < N; ++k)

           {

               Arr[k] = rand.Next() % 100;

               Console.Write("{0} ", Arr[k]);

           }

           Console.WriteLine();


           double avg = Arr.Average();

           int[] Bufer = new int[N];

           int i = 0, j = N - 1;


           Console.WriteLine("Среднее значение по массиву Avg = {0}", avg);

           for (int k = 0; k < N; ++k)

           {

               if (Arr[k] > avg)

               {

                   Bufer[i] = Arr[k];

                   i++;

               } else

               {

                   Bufer[j] = Arr[k];

                   j--;

               }

           }

           Arr = Bufer;


           Console.Write("Отсортированный массив: ");

           foreach (var el in Arr)

           {

               Console.Write("{0} ", el);

           }

           Console.WriteLine();

       }

   }

}



Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие ср
0,0(0 оценок)
Ответ:
WDGa5ter
WDGa5ter
28.03.2022 09:56

ответ:

для чего используются таблицы

итак, попытаемся ответить на следующий вопрос: что лучше — организовать информацию в таблицу или просто выровнять данные с клавиши ? что, вы никогда об этом не задумывались? думаем, такой вопрос — вообще не тема для дискуссии, поскольку тут, как говорится, двух мнений быть не может. судите сами.

клавиша удобна при работе с небольшими фрагментами текста. если же требуется организовать большие фрагменты данных, знакомства с таблицей вам не избежать.

таблица применяется в случае, если вам необходимо систематизировать в строки и столбцы довольно большой объем данных.

"клетка" таблицы называется ячейкой. в ячейку можно поместить текст (много текста) и графику.

текст в ячейках таблицы может иметь собственные поля и может быть отформатирован в виде абзацев. в ячейку вы вправе также поместить графику.

в отличие от текста, выровненного с клавиши , размеры таблицы вы имеете возможность изменять как угодно. поэтому, если вы собираетесь в будущем видоизменять способ представления данных, лучше поместить их в таблицу, нежели мучиться с примитивным текстом, отформатированным клавишей ,

к сожалению, word не сможет преобразовать ваш стол в стойку бара. (но поговаривают, что уже видели проспекты, в которых фирма microsoft анонсировала включение в word панели слесарного инструмента.)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота