Язык - PascalABC *ограничение по времени на тест: 1 секунда
*ограничение по памяти на тест: 256 мегабайт
*ввод: стандартный ввод
*вывод: стандартный вывод
В строке записана информация о количестве притоков рек.
Вывести название реки у которой наибольшее число притоков. Если таких рек несколько, то вернуть название последней из них.
Гарантируется, что в строке есть информация хотя бы об одной реке.
Входные данные
Дана строка, состоящая из слов. Под словом будем понимать последовательность любых символов (кроме пробелов), ограниченную пробелами или стоящую в начале или конце строки. Между словами, а также в начале и конце строки, может быть один или несколько пробелов.
Слово в данной строке – это _ .
Количество притоков – это целое, не отрицательное число, меньшее 10000.
Выходные данные
Название реки.
For example:
Input:
Lena_4 Yenisei_5 Volga_3
Result:
Yenisei
#include <iostream>
#include <conio.h>
using namespace std;
void main()
{
setlocale(LC_ALL, "Russian");
system("title Материалы");
system("color 74");
int material;
start:
system("CLS");
cout << "Введите число для уточнение названия детали:\n";
cin >> material;
switch (material)
{
case 1: cout <<"Шуруп\n";
break;
case 2: cout<<"Гайка\n";
break;
case 3: cout<<"Винт\n";
break;
case 4: cout<<"Гвоздь\n";
break;
case 5: cout<<"Болт\n";
break;
default: cout<<"Предмет не найден\n";
break;
}
getch();
goto start;
}
1 Отрицание-инверсия(не, обозначается - )
2Действия в скобках
3 Конъюнкция-умножение(и, обозначается&)
4 Дизъюнкция-сложение(или, обозначается галочкой)
истина-1,ложь-0
например:
1галочка0&1 следуя по всем законам математики, сначала выполняется умножение т.е & значит 0*1=0, а затем выполняем сложение(галочка) 1+0=1 следовательно ответ истина
1) 1&0=0-ложь
2)1 галочка0=1-истина
3) не 1 галочка 0 - 0+0=0-ложь
4)1 & 0 галочка 1=1*0+1= 1-истина
5)1 галочка 0&1=1+0*1=1-истина
6)не1 галочка 0 &1=0+0*1=0-ложь
7)(1галочка0) &(1галочка0)=(1+0)*(1+0)=1*1=1-истина
8)не(1галочка0) & (1галочка0)=не(1+0)*(1+0)=не1* 1=0*1=0-ложь
9)не(1&0&1)=не(1*0*1)=не(0*1)=не0=1-истина