В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DenisPalashyk
DenisPalashyk
19.05.2023 04:40 •  Информатика

Язык кода Python. Игра «Компьютер угадывает число»
Поменяйте мальчика и компьютер из задачи местами. Теперь мальчик загадывает число между 1 и 100 (включительно). Компьютер может спросить у мальчика: «Твое число равно, меньше или больше, чем число N?», где N — число, которое хочет проверить компьютер. Мальчик отвечает одним из трёх чисел: 1 — равно, 2 — больше, 3 — меньше.
Напишите программу, которая с цепочки таких вопросов и ответов мальчика угадывает число.
Дополнительно: сделайте так, чтобы можно было гарантированно угадать число за семь попыток.

Показать ответ
Ответ:
001Карина11111
001Карина11111
28.03.2021 16:33

import random

right_ans = int(input('Введите число от 1 до 100: '))

a = 1

b = 101

right = False

tries = 1

while not right:

 comp_answer = random.randint(a, b)

 if comp_answer > right_ans:

   b = comp_answer

 elif comp_answer < right_ans:

   a = comp_answer + 1

 else:

   print(f'Yes, thats it, computer guessed with {tries} attempts')  

   right = True

 tries += 1

0,0(0 оценок)
Ответ:
alesyshapiro
alesyshapiro
28.03.2021 16:33

class Finder:

   def __init__(self):

       self.current_range = range(1, 101)

   def condition(self, user_select):

       if user_select == '1':

           return True

       elif user_select == '2':

           self.current_range = range(int(self.current_half + self.current_range.start), self.current_range.stop)

           return False

       elif user_select == '3':

           self.current_range = range(self.current_range.start, int(self.current_half + self.current_range.start))

           return False

   @property

   def current_half(self) -> int:

       return int((self.current_range.stop - self.current_range.start) / 2)

finder = Finder()

while True:

   user_select = input(f'Это {finder.current_half + finder.current_range.start}?\n')

   result = finder.condition(user_select)

   if result:

       break

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота