В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
чивапчич
чивапчич
14.02.2021 22:44 •  Информатика

Взаданном одномерном массиве поменять местами соседние элементы. напишите программу на паскале, заранее !

Показать ответ
Ответ:
gea99
gea99
23.06.2020 14:49
Var
  n, i, c : integer;
  a : array [1..1000] of integer;
begin
  read (n);
   for i := 1 to n do read (a[i]);
  for i := 1 to n div 2 do
  begin
    c := a[i*2];
    a[i*2] := a[i*2-1];
    a[i*2-1] := c;
  end;
  for i := 1 to n do
    write (a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота