В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
раопп
раопп
17.05.2023 15:33 •  Информатика

Выполните практическую работу: составить программу-Pascal для решения задачи «Скидка»: при покупке на сумму от 3000 руб. покупатель получает 1% скидки, от 5000 руб. –3% скидка, от 8000 руб. –5% скидка, от 20000 руб. –10% скидка. Тело программы должно содержать настоящую фамилию ученика, например, begin writeln(‘Петров Дмитрий’);Входные данные –сумма покупки. Вывод на экран: Сумма <число> Скидка <число> Оплата <число>

Показать ответ
Ответ:
28номер
28номер
20.11.2020 22:48

1

Объяснение:

Для начала посчитаем выражения в первой скобке:

512^78 = 2,1040543606193494028963959531521e+211‬

512^60 = 3,5991310356345571062484308061488e+162‬

Вычитаем: 512^78-512^60 = 2.104054e+211

Теперь во второй:

512^5 = 35 184 372 088 832‬ (35 триллионов 184 миллиарда 372 миллиона 88 тысяч 832)

64^5 = 1 073 741 824‬ (1 миллиард 73 миллиона 741 тысяча 824)

Вычитаем: 35 184 372 088 832 - 1 073 741 824‬ = 35 183 298 347 008‬

Считаем общее выражение:

(512^78-512^60)*(512^5+64^5) = 7.403209e+224

Получается, одна цифра 7.

Надеюсь

0,0(0 оценок)
Ответ:
regina290402
regina290402
06.08.2021 19:59

A[i] := i + 1;

   PrintLn(a);

   Println();

   for i := 1 to 10 do

   begin

       A[i] := A[i - 1];

       PrintLn(a);

   end;

   

   Println();

   Println(2);

   for i := 0 to 10 do

       A[i] := i + 1;

   PrintLn(a);

   Println();

   for i := 10 downto 0 do

   begin

       A[i] := A[10 - i];

       PrintLn(a);

   end;

end.

Тут вывод трасировок последних циклов

1

[1,2,3,4,5,6,7,8,9,10,11]

[1,1,3,4,5,6,7,8,9,10,11]

[1,1,1,4,5,6,7,8,9,10,11]

[1,1,1,1,5,6,7,8,9,10,11]

[1,1,1,1,1,6,7,8,9,10,11]

[1,1,1,1,1,1,7,8,9,10,11]

[1,1,1,1,1,1,1,8,9,10,11]

[1,1,1,1,1,1,1,1,9,10,11]

[1,1,1,1,1,1,1,1,1,10,11]

[1,1,1,1,1,1,1,1,1,1,11]

[1,1,1,1,1,1,1,1,1,1,1]

2

[1,2,3,4,5,6,7,8,9,10,11]

[1,2,3,4,5,6,7,8,9,10,1]

[1,2,3,4,5,6,7,8,9,2,1]

[1,2,3,4,5,6,7,8,3,2,1]

[1,2,3,4,5,6,7,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

[1,2,3,4,5,6,5,4,3,2,1]

Подробнее - на -

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота