Выполнить на ПАСКАЛЕ!! Известны данные среднемесячной зароботной платы продавцов в трех магазинах райпо. Определить среднее значение зароботной платы в этих магазинах.
Ну почему,когда просят написать программу никто никогда не указывает язык программирования.я напишу на языке паскаль с входным и выходным файлом,но если это не тот язык,твоя проблема.(сообщения в фигурных скобках,это комментарии,просто для пояснение,можешь удалить их)
program p1; const n=10; var a : array[1..n] of integer; i,b,c:integer; begin randomize; assign(input,'input.txt'); reset(input); assign(output,'output.txt'); rewrite(output);
for i:=1 to n do {Заполнение исходного массива} a[i]:=random(21)-10;
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)} write(a[i]:4);
c:=0; {Инверсия массива} for i:=1 to 2 do begin b:=a[i]; a[i]:=a[5-c]; a[5-c]:=b; c:=c+1; end; c:=0; for i:=6 to 8 do begin b:=a[i]; a[i]:=a[10-c]; a[10-c]:=b; c:=c+1; end; writeln;
for i:=1 to n do {Вывод инверсированого массива} write(a[i]:4);
Ясно, что между кинотеатром и булочной находятся аптека и универсам. Из фразы "второй дом после универсама- это ..." следует, что существуют два дома после универсама. А это означает, что универсам второй по порядку. Тогда аптека - третья.
следующий дом после кинотеатра- это универсам второй дом после универсама- это аптека второй дом после кинотеатра- это аптека кинотеатр называется "Сказка" следующий дом после универсама- это аптека. предыдущий дом перед аптекой - это универсам предыдущий дом перед аптекой- это универсам.
program p1;
const n=10;
var a : array[1..n] of integer;
i,b,c:integer;
begin
randomize;
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
for i:=1 to n do {Заполнение исходного массива}
a[i]:=random(21)-10;
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)}
write(a[i]:4);
c:=0; {Инверсия массива}
for i:=1 to 2 do begin
b:=a[i];
a[i]:=a[5-c];
a[5-c]:=b;
c:=c+1;
end;
c:=0;
for i:=6 to 8 do
begin
b:=a[i];
a[i]:=a[10-c];
a[10-c]:=b;
c:=c+1;
end;
writeln;
for i:=1 to n do {Вывод инверсированого массива}
write(a[i]:4);
close(input);
close(output);
end.
следующий дом после кинотеатра- это универсам
второй дом после универсама- это аптека
второй дом после кинотеатра- это аптека
кинотеатр называется "Сказка"
следующий дом после универсама- это аптека.
предыдущий дом перед аптекой - это универсам
предыдущий дом перед аптекой- это универсам.