В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
drshev
drshev
16.08.2022 08:41 •  Информатика

Вычислить: номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.написать программу в

Показать ответ
Ответ:
kukovofiwi342
kukovofiwi342
16.07.2020 20:53
const  n = 5;   var   a: array[1..n] of integer;   i, k: integer;   s: real;   begin   s := 0;   for i := 1 to n do   begin     readln(a[i]);     s := s + a[i];   end;   s := s / n;   writeln('Среднее значение = ', s:0:3);   k := 1;   for i := 2 to n do     if abs(a[k] - s) > abs(a[i] - s) then k := i;     writeln('Индекс элемента: ', k, ' Значение = ', a[k]); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота