Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
dikinova2017ozio8q
11.10.2020 02:39 •
Информатика
Вязыке pascal есть функция pandom (a), которая служит для получения случайного ряда чисел из интервала (0; а). вопрос: придумать, как можно при формул языка pascal сделать так, чтобы случайные числа выпадали в интервале (a; b)
Показать ответ
Ответ:
pitonpitonov
23.05.2020 16:59
Если переменная нужна целая то так:
x:=random(b-a)+a
Если можно дробную, то так
x:=(b-a)*random+a
0,0
(0 оценок)
Популярные вопросы: Информатика
kaban229
04.12.2022 04:13
Решите задачи по информатике...
Quickfast77
06.02.2020 05:00
решить задачу на С++. Найти сумму элементов квадратной матрицы, находящихся по периметру этой матрицы и сумму элементов на ее диагоналях. Если первая сумма больше второй,...
чек14
07.11.2021 18:01
По заданной логической функции построить логическую схему и таблицу истинности Выписать из логической схемы соответствующую ей логическую формулу:...
Koskool
08.04.2021 23:03
В одной из кодировок Unicode каждый символ кодируется 16 битами. Юля написала текст (в нём нет лишних пробелов): Вена, Тирана, Минск, Брюссель, Ватикан, Рейкьявик, Рим,...
ден1005
27.12.2021 12:32
НЕТ ВРЕМЕНИ! Дана программа на языке Pascal: Program num1; var a, b, c, m : integer; Begin writeln( Введите три числа ); readln(a, b, c); m := a; if b if c writeln(m);...
you58
29.08.2021 23:18
Выполнить указанные переводы чисел из одной системы в другую: 2А, 4(16)=Х(10) 56,875(10)=Х(2) 324,015625(10)=Х(8) 765,125(10)=Х(16)...
vasilisasimakin
21.01.2023 13:53
Напишите программу в Паскаль: 1) Найти сумму элементов массива, оканчивающихся на 3. 2) Найти произведение элементов массива, кратных 5. (10 класс)...
p1ayer1337
02.03.2023 10:11
Укажи минимальный объём памяти (в битах), достаточный для хранения любого растрового изображения размером 70×70 пикселя, если известно, что в изображении используется...
TheCool111
12.07.2021 22:20
В программе используется одномерный целочисленный массив А с индексами от 0 до 9 значения элементов равны 6 14 25 43 37 21 15 18 24 30 соответственно, т.е А[0] = 6,...
dynn
11.01.2022 11:35
Соответствие между изображениями символов и кодами символов устанавливается с автофигуры графические схемы шифрование текста кодовые таблицы...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Если переменная нужна целая то так:
x:=random(b-a)+a
Если можно дробную, то так
x:=(b-a)*random+a