В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AGIDELKA2004
AGIDELKA2004
04.07.2020 20:07 •  Информатика

Вязыке c написать программу:
использование оператора выбора case.
с 1 января 1990 года по некоторый день месяцев и n дней, определить название текущего месяца.

Показать ответ
Ответ:
Kachmaresghg
Kachmaresghg
29.06.2020 23:44

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Ответ:
Alina1536
Alina1536
09.04.2021 00:01

Объяснение:

Допустим, у нас есть сообщение «habr», которое необходимо передать без ошибок. Для этого сначала нужно наше сообщение закодировать при Кода Хэмминга. Нам необходимо представить его в бинарном виде.На этом этапе стоит определиться с, так называемой, длиной информационного слова, то есть длиной строки из нулей и единиц, которые мы будем кодировать. Допустим, у нас длина слова будет равна 16. Таким образом, нам необходимо разделить наше исходное сообщение («habr») на блоки по 16 бит, которые мы будем потом кодировать отдельно друг от друга. Так как один символ занимает в памяти 8 бит, то в одно кодируемое слово помещается ровно два ASCII символа. Итак, мы получили две бинарные строки по 16 битбит. распараллеливается, и две части сообщения («ha» и «br») кодируются независимо друг от друга. Рассмотрим, как это делается на примере первой части.

Прежде всего, необходимо вставить контрольные биты. Они вставляются в строго определённых местах — это позиции с номерами, равными степеням двойки. В нашем случае (при длине информационного слова в 16 бит) это будут позиции 1, 2, 4, 8, 16. Соответственно, у нас получилось 5 контрольных бит (выделены красным цветом)Таким образом, длина всего сообщения увеличилась на 5 бит. До вычисления самих контрольных бит, мы присвоили им значение «0».

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота