В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Максек1337
Максек1337
05.03.2020 19:50 •  Информатика

Ввести двузначное целое число х< 15. написать программу перевода его в восьмеричную систему счисления.(паскаль)

Показать ответ
Ответ:
77Stranik77
77Stranik77
08.10.2020 17:36
Странное задание!
Если число целое и двухзначное меньше 15, то это числа 10, 11, 12, 13 и 14. В восьмеричном представлении они больше десятичного значения на 2, т.е. 10₁₀ = 12₈, 11₁₀ = 13₈, ... 14₁₀ = 16₈

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите число от 10 до 14:');
  Writeln('В восьмеричной системе оно записывается как ',n+2)
end.

Пример
Введите число от 10 до 14: 13
В восьмеричной системе оно записывается как 15
0,0(0 оценок)
Ответ:
arinuchik
arinuchik
08.10.2020 17:36
Const zs='01234567'; //цифры в 8 СС
s:string;
begin
write('Введите число в 10 СС: ');
readln(n);
s:='';
while n>0 do
begin
s:=zs[n mod 8+1]+s; //берем остаток от деления на 8 и эту цифру пишем в начало строки
n:=n div 8 //сокращаем число
end;
write('Число в 8 СС: ',s);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота