Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Kiska41384
30.03.2023 16:17 •
Информатика
Ввести двумерный массив аnxm.каждый элемент в массиве чье значение лежит вне диапазона [-8; 6] возвести в квадрат.массив вывести до и после преобразования с++
Показать ответ
Ответ:
Kurbanovaarina
03.10.2020 18:33
#include <iostream>
//Размерность#define n 3#define m 3
//Диапозон#define d_min -8#define d_max 6
void enter_arr(int a[n][m]) { printf("\n >> Введите элементы массива %dx%d\n",n,m); for (int i = 0; i < n; i++) { printf("\n"); for (int j = 0; j < m; j++) { printf(" << a[%d][%d] = ", i+1, j+1); scanf("%d",&a[i][j]); } }}
void print_arr(int a[n][m]) { printf("\n >> Массив %dx%d :", n, m); for (int i = 0; i < n; i++) { printf(" \n >> "); for (int j = 0; j < m; j++) printf("%d ", a[i][j]); }}
int main(){ setlocale(LC_ALL, "rus"); int a[n][m];
enter_arr(a); print_arr(a);
for (int i = 0; i < n; i++) for (int j = 0; j < m; j++) if ((a[i][j] < d_min) || (a[i][j] > d_max)) a[i][j] *= a[i][j];
print_arr(a);
system("pause>>void"); return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
идинахер89
27.06.2022 06:57
При какого свойства проверяется установка флажков?...
Лола666484
23.10.2022 23:26
Практическая работа. Охотник Владимир Фёдорович всегда берет с собой на охоту собаку Шарика, который загоняет для него зверя. В декабре собака добыла 5 зайцев и 1 волка, в...
anyta03
29.07.2022 13:28
1. Що таке НТМL-документ? 2. Де можна створювати веб-сторінки і веб-сайти? 3. Назвіть етапи створення сайта. 4. Опишіть етапи створення сайта. 5. Які структури сайта ви знаєте?...
ноди1
02.12.2021 02:21
3. Найдите значения логических выражений: а) (x2+1)= 1v(х+1) 1 /\] (х4+ 0);б)] (x2+a2) 1/\(х4+1) 1 \/(x3 = 0);в) (а2+b2) 2-a:bл(а?-b2) 22*a*b;г) (1000в двоичной системе счисления=10в...
Girfans
25.07.2021 08:00
Здравствуйте с информатикой. Нужно по схеме составить пример....
samiragubai
28.10.2022 06:03
Упрости и запиши верный ответ. (D∨N)&(D∨N¯¯¯)...
TheCosmos
13.09.2020 01:15
Написать программу подсчитывающую кол-во чётных и нечётных цифр в числе....
neznaika168
13.09.2020 01:15
1)часть текстового документа (6 букв) 2) фрагмент текста, выражающий законченную мысль (5 букв) 3) последовательность символов алфавита (единица речи ) (5 букв)...
Милан228
13.09.2020 01:15
Закончите фразу: « для того чтобы объединить две строки в одну, нужно установить курсор и нажать клавишу » возможен ли другой если да, то какой?...
yan0125
13.09.2020 01:15
Чем расчетная анимация отличается от покадровой...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Размерность#define n 3#define m 3
//Диапозон#define d_min -8#define d_max 6
void enter_arr(int a[n][m]) { printf("\n >> Введите элементы массива %dx%d\n",n,m); for (int i = 0; i < n; i++) { printf("\n"); for (int j = 0; j < m; j++) { printf(" << a[%d][%d] = ", i+1, j+1); scanf("%d",&a[i][j]); } }}
void print_arr(int a[n][m]) { printf("\n >> Массив %dx%d :", n, m); for (int i = 0; i < n; i++) { printf(" \n >> "); for (int j = 0; j < m; j++) printf("%d ", a[i][j]); }}
int main(){ setlocale(LC_ALL, "rus"); int a[n][m];
enter_arr(a); print_arr(a);
for (int i = 0; i < n; i++) for (int j = 0; j < m; j++) if ((a[i][j] < d_min) || (a[i][j] > d_max)) a[i][j] *= a[i][j];
print_arr(a);
system("pause>>void"); return 0;}