В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Ввести два целочисленныхмассива − по 10 элементов в каждом. сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.написать программу на паскале

Показать ответ
Ответ:
morfisleep
morfisleep
24.07.2020 19:19
Скрин с результатом работы программы прикрепил.

var a:array[1..10] of integer;
b:array[1..10] of integer;
c:array[1..10] of integer;
i:integer;
begin
write ('Введите массив 1: ');
for i:=1 to 10 do
read (a[i]);
WRITELN;
write ('Введите массив 2: ');
for i:=1 to 10 do
read (b[i]);
WRITELN;
WRITELN;
write ('Массив 3: ');
for i:=1 to 10 do
begin
if i mod 2 <> 0 then c[i]:=b[i+1];
if i mod 2 = 0 then c[i]:=a[i-1];
write (c[i],' ');
end;
end.

Ввести два целочисленныхмассива − по 10 элементов в каждом. сформировать новый массив, на четных мес
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота