В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SashaPolishuk
SashaPolishuk
14.03.2020 16:38 •  Информатика

всем добрый день!
метод симплекс
мне нужно написать программу ,вычисляющую на языке с++ или же с#
f = 10x1+12x2+14x3+11x4
при следующих ограничениях
x1+x2+2x3+x4+x5=100
2x1+3x2+3x3+4x4+x6=180
3x1+3x2+2x3+4x4+x7=160
,

Показать ответ
Ответ:
masha3323
masha3323
01.11.2022 12:23
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
0,0(0 оценок)
Ответ:
elvirabondar2
elvirabondar2
17.10.2022 12:26
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота