В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
IronGold
IronGold
28.09.2022 18:54 •  Информатика

ВСЕ ЗАДАНИЯ НАДО СДЕЛАТЬ ЧЕРЕЗ QBasic 1 Составить программу, выводящую на экран числа от 1 до 10
2 Написать программу вычисления произведения 1*3*5…N
3 Составить программу для вывода на экран любой таблицы умножения.
Пояснение: пользователь вводит число от 1 до 10, программа выдает таблицу умножения на это число.
4 Изобразить при оператора PSET (x,y) фантастическое созвездие.

Показать ответ
Ответ:
goldsskyp02hwt
goldsskyp02hwt
01.09.2020 03:04

Python:

# A

print(len([i for i in range(1000, 10000) if i % 7 == 0]))

# B

for i in range(100, 1000):

   if all([i % 15 == 11, i % 11 == 9]):

       print(i)

# C(1)

N = int(input())

numbers = [i for i in range(1, N+1)]

result = numbers[0]

for i in numbers[1:]:

   result *= i

print(result)

# C(2)

import math

print(math.factorial(int(input(

# D

for i in range(100, 1000):

   digits = [int(n) for n in str(i)]

   with_a_degree = [n ** len(str(i)) for n in digits]

   if sum(with_a_degree) == i:

       print(i)

0,0(0 оценок)
Ответ:
lizabobovic
lizabobovic
01.07.2020 07:56

1. 55

2. 21

Объяснение:

1.

for i:=1 to 10 do a[i]:=i; - заполнение массива (элемент равен своему индексу)

i = 1   a[1] = 1

i = 2   a[2] = 2

i = 3   a[3] = 3

i = 4   a[4] = 4

i = 5   a[5] = 5

i = 6   a[6] = 6

i = 7   a[7] = 7

i = 8   a[8] = 8

i = 9   a[9] = 9

i = 10   a[10] = 10

for i:=1 to 10 do write ('a[',i,']=',a[i],' '); - вывод элементов массива на экран (в одну строку в виде a[1]=1 a[2]=2 и т.д.)

s = 0

s = s + a[i] (считаем сумму элементов)

s = 0 + 1 + 2 + 3 + 4 + 5 + 6 + 7 + 8 + 9 + 10 = 55

2.

for i:=1 to 10 do a[i]:=i+1; - заполнение массива (элемент равен своему индексу плюс единица)

i = 1   a[1] = 1 + 1 = 2

i = 2   a[2] = 2 + 1 = 3

i = 3   a[3] = 3 + 1 = 4

i = 4   a[4] = 4 + 1 = 5

i = 5   a[5] = 5 + 1 = 6

for i:=1 to 10 do write ('a[',i,']=',a[i],' '); - вывод элементов массива на экран (в одну строку в виде a[1]=1 a[2]=2 и т.д.)

s = 1

s = s + a[i] (считаем сумму элементов, учитывая начальное значение s)

s = 1 + 2 + 3 + 4 + 5 + 6 = 21

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота