В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Все задачи нужно выполнить в Паскале.

1. Рассчитать значения y при каждом х. х= 3, 4, ..., 15:

y = 7t3 - 6t +10, если t = x - 2.

2. Составить программу, которая запрашивает пароль (двузначное число + 4 символа) до тех пор, пока он не будет правильно введен. Верный пароль должен быть задан в виде константы.

3.Из натурального трехзначного числа удалить заданную цифру. Число и цифру вводить с клавиатуры.

4. Вводится четырёхзначное число (xysz). Вывести сумму xy + sz. Начальные данные необходимо ввести с клавиатуры.

В отчет включить коды программ на Паскале и результаты работы в виде скриншотов окна программ. Все необходимые входные данные задать самостоятельно.

Показать ответ
Ответ:
Anastasia12578
Anastasia12578
21.12.2020 01:18

1 программа:

var x, y, t:integer;

begin

 for x:=3 to 15 do begin

   writeln('x = ', x);

   t := x - 2;

   y := 7*t*3-6*t+10;

   writeln('y = ', y);

   writeln('');

 end;

end.

2 программа:

const pass ='45xlua';

var x:string;

a:boolean;

begin

 a:= false;

 while a<>true do begin

    writeln('Введите пароль');

    readln(x);

    if x = pass then begin

      a:=true;

      writeln('Пароль верный');

      end

    else

      writeln('Пароль неверный, введите еще раз');

    writeln('');

 end;

end.

4 программа:

var a, a1, a2, x, kol:integer;

begin

writeln('Введите четырёхзначное число');

readln(a);

x := a;

while x<>0 do begin

  x:= x div 10;

  kol:= kol + 1;

  end;

 if (kol = 4) then begin

   a1 := a div 100;

   a2:= a mod 100;

   writeln(a1+a2);

 end

  else

    writeln('Число не является четырёхзначным');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота