Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Географица00
16.08.2022 11:02 •
Информатика
Все свои напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе длины сторон треугольника.
Показать ответ
Ответ:
05061972
07.10.2020 19:34
Var
a, b, c: real;
begin
Read(a, b, c);
if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
Writeln('Треугольник прямоугольный!')
else
Writeln('Треугольник непрямоугольный!')
end.
Пример:
3 4 5
Треугольник прямоугольный!
0,0
(0 оценок)
Популярные вопросы: Информатика
пончик123456798
10.05.2023 20:17
В коробку помещается 16 спичек. сколько потребуется коробок чтобы поместить 130 спичек...
Limon4iK1000
18.02.2023 03:01
Текст составлен с использованием алфавита мощностью 64 символа и содержит 100 символов. каков информационный объем текста?...
vipmurlyan
18.02.2023 03:01
Напишите программу которая в последовательности натуральных чисел определяет количество чисел кратных 4. программа получает на вход количество чисел в последовательности,...
alanuit
08.03.2022 18:01
50 в цветовой модели rgb для кодирования одного пикселя используется 3 байта. фотографию размером 1772×4488 пикселей сохранили в виде несжатого файла с использованием...
sacha0457
08.01.2020 10:36
ответить на билет , , . билет n 8 1. дайте характеристику и назначение языка си. 2. как записываются арифметические выражения? 3. чем отличается функция от процедуры?...
elinatyul
08.03.2021 23:14
Сообщение занимает 3 страницы и содержит 7875 байтов информации. сколько строк в тексте, если символов в строке 50 и при составлении этого сообщения использовали 128...
оля1874
17.09.2020 16:48
Родители взяли в банке кредит 5000 р сроком на год под 15 проц. ежемесячно. сколько денег они заплатят банку через год? решите )...
KotickMacks
13.07.2021 23:14
Что такое права и что такое обязанности?...
irina18221
13.07.2021 23:14
На отрезке ав длиной 12 см отмечена точка с так что ас равна 10 см и точка д так что сд равна 5 см найди длину отрезка вд. надо нарисовать рисунок....
kauymovemil
13.07.2021 23:14
:запишите в виде чила разрядную единицу - миллион...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a, b, c: real;
begin
Read(a, b, c);
if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
Writeln('Треугольник прямоугольный!')
else
Writeln('Треугольник непрямоугольный!')
end.
Пример:
3 4 5
Треугольник прямоугольный!