В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
annya306
annya306
02.09.2020 23:51 •  Информатика

Впрограмме обрабатывается одномерный целочисленный массив а с индексами от 0 до 9. значения элементов равны 8; 5; 11; 4; 6; 9; 4; 10; 7; 8 соответственно, т.е. a[0]=8; a[1]=5 и т.д. определите значение переменной s после выполнения следующего фрагмента программы, записанного ниже на паскале k: =0; t: =0; for i: =0 to 9 do if a[i]> k then begin t: =k; k: =a[i] end else t: =a[i]; s: =k+t;

Показать ответ
Ответ:
222вовчик222
222вовчик222
02.10.2020 18:15
Const
  A: array of integer=(8, 5, 11, 4, 6, 9, 4, 10, 7, 8);
var
  k, t, i, S: integer;
begin

k:=0; t:=0;
for i:=0 to 9 do
if A[i]>k then begin
t:=k;
k:=A[i]
end
else
t:=A[i];
S:=k+t;

writeln(S);
end.

ответ: 19
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота