В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruzmat84ot4xqh
ruzmat84ot4xqh
24.03.2021 22:52 •  Информатика

Впитоне (python). 20 .
напишите программу, которая открывает этот файл на чтение, построчно считывает из него данные и записывает строки в другой файл, заменяя числительные , которые содержатся в списке (["один", "два", "три", "четыре", "пять" определенном до открытия файлов.

буду .

Показать ответ
Ответ:
kristinarepina
kristinarepina
22.03.2022 14:18
118. Даны коэффициенты квадратного уравнения a,b,c. Найти действительные корни этого уравнения.

program Kv_ur;
var a,b,c,x1,x2,D: real;
begin
Writeln ('Для решения квадратного уравнения');
Writeln ('Введите коэффициент a');
Readln (a);
Writeln ('Введите коэффициент b');
Readln (b);
Writeln ('Введите коэффициент c');
Readln (c);
D:=Sqr(b)-4*a*c;
If d<0 then Writeln ('Так как дискрименант ',D,'<0 уравнение не имеет решений');
     begin
       If d=0 then
               begin
                   x1:=-b/(2*a);
                   Writeln ('Так как дискриминант равен 0 уравнение имеет один корень:');
                   Writeln(x1);
               end;
              If d>0 then
               begin
                   x1:=(-b- Sqrt(Sqr(b)-4*a*c))/2*a;
                   x2:=(-b+ Sqrt(Sqr(b)-4*a*c))/2*a;
                   Writeln ('Так как дискриминант ',D,'>0 уравнение имеет два корня:');
                   Writeln ('x1=', x1, ' и x2=', x2);
               end;
  end;
end.  

122. Можно ли прямоугольный пакет размерами A,B,C положить в чемодан размерами X,Y,Z?  
program chemodan;
var a,b,c,x,y,z: real;
begin
Writeln ('введите размеры пакета');
 Writeln ('Введите длину a');
Readln (a);
Writeln ('Введите ширину b');
Readln (b);
Writeln ('Введите высоту c');
Readln (c);
Writeln ('введите размеры чемодана');
Writeln ('Введите длину х');
Readln (x);
Writeln ('Введите ширину y');
Readln (y);
Writeln ('Введите высоту z');
Readln (z);  
If (a<=x) and (b<=y) and (c<=z) then Writeln ('пакет можно положить')
else Writeln ('пакет положить нельзя');
End.  
0,0(0 оценок)
Ответ:
Artemo4ka123
Artemo4ka123
16.08.2022 23:41
 const     
z = 30; // максимально число слов  
var   
s,w : string;   
n,p,i,j,l : integer;   
words : array [1..z] of string;   
kw : array [1..z] of integer;   
r : boolean;    
begin 
writeln ('введите строку'); 
readln (s); 
writeln ('укажите кол-во повторений'); 
readln (n);   
l := Length(s); 
p := 1; 
w := '';    
 for i := 1 to l do       
 if (s[i] <> ' ') and (s[i] <> '.') and (s[i] <> ',') then   
   w := w + s[i]    
    else     
begin   
  for j := 1 to p do   
   if w = words[j] then 
      begin   
      kw[j] := kw[j] +1;   
     r := true;     
   end;        
      if not r then   
    begin   
      p := p +1;   
      words[p] := w; 
       kw[p] := kw[p] +1;     
   end;    
    w := '';   
  r := false;   
      end;   
      for i := 1 to p do 
  if kw[i] > n then 
  writeln (words[i]);      
      end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота