В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ԺⱭNÍYⱭ
ԺⱭNÍYⱭ
22.10.2020 10:09 •  Информатика

Впитоне напишите программу, которая определяет, является ли заданная строка (возможно, содержащая пробелы) палиндромом, то есть верно ли, что она после удаления пробелов читается одинаково слева направо и справа налево. входные данные входная строка – последовательность символов, возможно, содержащая пробелы. выходные данные программа должна вывести слово 'yes', если введённая строка – палиндром, и слово 'no', если она не является палиндромом. примеры входные данные ka za k выходные данные yes входные данные kaza n выходные данные no сдать:

Показать ответ
Ответ:
Valentinka079
Valentinka079
08.09.2019 16:10
На примере в этой   program z1; uses crt; const st1='ма'; st2='ма'; var str: string; i,k: integer; begin write('введите строку: '); readln(str); for i: =1 to length(str) do if (st1=copy(str,i,2)) or (st2=copy(str,i,2)) then k: =k+1; writeln(k); end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота