Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
fhchfyhf1
18.06.2022 01:42 •
Информатика
Впаскале вводится сначала число n, а затем n чисел. выведите эти n чисел в следующем порядке: сначала выводятся все нечетные числа в том порядке, в каком они встречались во входном файле, а затем - все четные.
Показать ответ
Ответ:
Лолыч11
17.07.2020 09:02
Var a:array of integer;
n,i:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
for i:=0 to n-1 do if a[i] mod 2=1 then write(a[i],' ');
writeln();
for i:=0 to n-1 do if a[i] mod 2=0 then write(a[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Элина2018
31.12.2022 05:52
Срешением, ! требуется отсортировать массив по неубыванию методом пузырька . входные данные в первой строке вводится одно натуральное число, не превосходящее 1000 – размер...
alan4ik1324
07.09.2020 20:59
2. Одределете значение переменной А после выполнения фрагмента АлгоритмаА:=3В:=3НцВ:=в/2А:=а*вКц при в=2...
igor2312
11.12.2021 06:21
Записать код страницы упражнения 5 и 6....
TonyaOgneva
18.04.2022 14:37
Монитор ASUS va24e ,не могу изменить соотношение сторон с 16:9 на 4:3, есть меню, но строка Формат экрана недоступна ответить на вопрос...
belkairi
26.10.2022 18:08
у меня сор по информатике ...
Сирена11111
12.04.2022 05:27
Система команд исполнителя Робот: вверх, вниз, вправо, влево, закрасить. Запишите алгоритм для исполнителя, чтобы получился следующий рисунок:...
Dashasdh
14.05.2020 13:05
Для увеличения рисунка по вертикали в 2 раза надо: а)выбрать команду изменить размер,в поле по вертикали написать в)выбрать команду изменить размер, в поле по вертикали...
Dashasha555
19.08.2022 22:50
в одному полі бази данних можуть зберігатися дані тільки одного типу . погоджуюсь чи не погоджуюсь даю максимальную оценку...
UskovaV99
23.08.2020 15:36
Мне нужно решить 5 и 6 задание которое на скриншоте...
shluhiNovokrai
07.01.2022 18:45
Что будет выведено на экран в результате выполнения фрагмента программы: a = 16 b = 14 + a print( b= , b)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n,i:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
for i:=0 to n-1 do if a[i] mod 2=1 then write(a[i],' ');
writeln();
for i:=0 to n-1 do if a[i] mod 2=0 then write(a[i],' ');
end.