Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
vddrobysheva
15.11.2022 11:27 •
Информатика
Впаскале составить программу которая для натуральных чисел m и n находит min(2n,m)*nod(2n,3m)
Показать ответ
Ответ:
lyskoyana39
05.10.2020 18:44
PascalABC.NET 3.x
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72
0,0
(0 оценок)
Популярные вопросы: Информатика
bronebor
09.06.2023 15:49
Определить длительность звучания стереоаудиофайла, занимающего 6000 кбайт памяти при глубине звука 16 бит и частоте 48 кгц....
masha19902
10.03.2022 21:34
Ребят исправить ошибку в программе. Выдаёт ошибку там где d:= + . Я не понимаю что не так. Вот условие: с клавиатуры вводят символ операции и 2 числа. В зависимости от символа,...
Айгульнафис
21.12.2021 14:00
Компьютер, на котором предполагается работать с мультимедийными продуктами, должен быть дополнительно укомплектован...
ivanovaizl
26.05.2021 08:58
Выбери визуальные HTML-редакторы. HtmlDocEdit TOWeb Notepad++ Note Tab CoffeeCup Visual Site Designer 2.Выбери текстовые редакторы, которые можно использовать для создания...
sweet690
13.05.2021 22:26
Выберите верно заданный диапазон:В13:А6513:65В13:6513В:65АВ13^А65Определи количество ячеек в диапазоне C1:C7.Вычисли значение математического выражения в MS Excel: (76+100)−2(72:(7+13))....
nikitatutaev03
19.04.2022 00:07
Правописание ь Подчеркните слова, где нужно писать Ь. Громкий плач…, буду печ…, спряч…, певуч…, реж…, леч…, реч…, тише плач…, старая печ…, меч…, назнач…те, лож…, думаеш…,...
ruslan5632
19.04.2022 00:07
Как Кишу удалось стать вождем племени? Какой он использовал во время охоты на медведя? D сказке Сказание о Кише...
Пожалуйста1531
26.03.2023 13:06
DuckDoskenCowHoisila...
spirt708ozrmv0
05.06.2021 03:29
(37) Я сейчас вот пытаюсь описать свои мысли, а тогда это была какая-то безудержная радость, заполнившая всю мою душу. (38) Мне дали четыре года колонии. (39) Я отсидел,...
Kaka225
06.03.2023 08:57
Морфолокическйй разбор наречич...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72