В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
алиса673
алиса673
07.01.2020 23:19 •  Информатика

Впаскале. пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.

Показать ответ
Ответ:
katyagulina666
katyagulina666
13.06.2020 11:16

const d = 31;
var
  a: array[1..d] of integer;
  i, count, mdl: integer;
begin
  for i := 1 to d do begin
    a[i] := random(31);
    write(a[i], ' ');
    mdl := mdl + a[i];
  end;
  writeln;
  writeln('Средняя температура: ', (mdl / d):0:2);
  for i := 1 to d do
    if(a[i] > mdl / d) then inc(count);
  writeln('Дни, в которые температура была выше средней: ', count);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота