Впаскале. написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности действительных чисел. количество чисел должно задаваться во время работы программы. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделено полу жирным шрифтом). вычисления среднего арифметического последовательности действительных чисел. найдите количество чисел последовательности -> 15. введите последовательность. после ввода каждого числа нажмите enter. -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифметическое введенной последовательности: 4.00 для завершения работы программы нажмите enter.
Crt;
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n);
Write('Для завершения работы программы нажмите Enter');
Readkey
end.
Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter
Для версии Pascal.ABC.Net:
var
i,n:integer;
a,s:real;
begin
Writeln('Вычисление среднего арифметического');
Writeln('последовательности действительных чисел');
Write('Введите количество чисел последовательности ->');
Readln(n);
Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
s:=0;
for i:=1 to n do
begin
Read(a);
s:=s+a
end;
Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.